Suporte aos MODs/Hacks para phpBB.
  • Avatar do usuário
#281005
Existe um problema que estava encomodando muita gente que utiliza o phpBB-seo (http://www.phpbb-seo.com/) e a última versão do Support Toolkit.
Se você tiver os dois instalados no mesmo sistema phpBB, ao tentar entra no STK aparece o erro:

Non-static method utf_normalizer::nfkc() should not be called statically

Esse erro me encomodou por algum tempo, então deixo aqui registrado uma solução caso alguém passe pelo mesmo problema.

Abra:
/stk/common.php

Encontre:
Código: Selecionar todos
$stk_no_error = false;
Substitua por::
Código: Selecionar todos
$stk_no_error = true;
Outra "solução" seria utilizar uma versão anterior so STK e alterar no seu arquivo a versão, assim enganando o sistema.
Com uma versão antiga no STK, abrir o arquivo /stk/common.php
Nesse arquivo tem uma linha que informa a versão. Basta alterar o número da versão para a última, e assim o STK vai funcionar normalmente.
Código: Selecionar todos
// What version are we using?
define('STK_VERSION', '1.0.5');
//define('STK_QA', true);
Lembrando apenas que fazendo alguma dessas alterações você não tera mais o suporte oficial do phpbb.com.
Essas são soluções temporárias, até que esse problema seja resolvido.

Infelizmente ja limpei cache do forum do navegador[…]

Acesso via celular

Eu consegui acessar usando o Firefox. Deve ser mes[…]

Que eu saiba não tem

Eu gostava muito deste aqui https://www.coffeecup.[…]