Suporte à dúvidas gerais relacionadas ao phpBB 3.1.
Regras do fórum: Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca amarelo. Imagem
  • Avatar do usuário
  • Avatar do usuário
Avatar do usuário
By Vin
Posts Avatar
#296110
Eu estava editando uma mensagem no meu fórum e o mesmo erro apareceu lá no topo da tela, porém continuo conseguindo mexer em tudo normalmente, então não é só quando se usa o bbcode que especifiquei.
Avatar do usuário
By Vin
Posts Avatar
#296123
Chico Gois escreveu: 01 Fev 2018, 17:33 Está desatualizado, porque não atualiza?
Eu não atualizo para a 3.2 pois tem alguns bbcodes que não funciona, e no meu ACP não diz que há uma versão da 3.1 disponível..
Avatar do usuário
By Vin
Posts Avatar
#296124
Eu baixei o phpBB novamente e reinstalei o fórum e o erro persiste, alguma ideia do que pode ser? A versão continua sendo a 3.1.12, e diz estar atualizada... acham que um downgrade para a 3.1.0 pode corrigir?
Avatar do usuário
By Vin
Posts Avatar
#296126
Chico Gois escreveu: 05 Fev 2018, 17:45 Acho que é sua hospedagem
Uso uma VPS Linux, e nunca tive esse problema, já foi instalado outros fóruns com o mesmo apache e mesmo php, só agora que tá dando, mudei da versão 3.1.12 para 3.1.5 e continua o problema.

Edit: o meu php anterior era inferior ao 5.6, quando coloquei o 5.6 e instalei o fórum é que o erro veio, e não posso dar um downgrade no php por conta de aplicações na hospedagem que precisam dele.
Avatar do usuário
By Vin
Posts Avatar
#296127
Bom, o erro é no arquivo ./includes/message_parser.php, na linha 84, a única coisa que tem nessa linha é
Código: Selecionar todos
					if (preg_match($regexp, $this->message))
mas não vejo nada de errado.

Um colega meu me disse que está com o mesmo problema, e usa a mesma versão do php que eu, e no mesmo bbcode ([thumbnail]), o mesmo arquivo, mesma linha, e usamos a mesma versão do phpBB.
Configuração de Permissão

ACP > aba Geral > Ferramentas do fóru[…]