Suporte à dúvidas gerais relacionadas ao phpBB.
  • Avatar do usuário
  • Avatar do usuário
  • Avatar do usuário
Avatar do usuário
By Eron_moraes
Posts Avatar
#295898
Boa noite meus amigos!

Na pasta /forum eu possuo um fórum Phpbb3 instalado e funcionando (com versão PHP native 5.4) porem como ele esta desatualizado, eu criei uma nova instalação de fórum na pasta /phpbb (vou configurar e importar dados depois).

Porem, nessa nova versão do Phpbb3 ele exige uma versão mais atual do PHP (hoje o fórum esta usando o Native 5.4.).

Pergunto: Se eu alterar para a versão PHP 7.1, para poder trabalhar como o novo fórum em teste, o antigo vai parar de funcionar????
Avatar do usuário
By Chico Gois
Membership Days Avatar
#295899
Vamos lá,

Se a sua hospedagem permite selecionar a versão do PHP, todas as aplicações irão rodar nesta verão. Então o seu fórum oficial vai bugar.

Lembro de ter visto algo para rodar uma versão anterior no PHP7, vou ver se acho.
Avatar do usuário
By _Vinny_
Avatar
#295902
O phpBB 3.2 é totalmente compativel com a versão 7.1 do PHP. Já a versão 3.1 não tem compatibilidade com PHP 7.

Você pode deixar o PHP em 5.4 que é o minimo exigido pelo phpBB 3.2 enquanto você trabalha na atualização, então depois que terminar e o fórum mais antigo já estiver em pleno funcionamento na versão mais atual você pode se preferir mudar a versão do PHP para 7 ou superior, se for conveniente.
Avatar do usuário
By Eron_moraes
Posts Avatar
#295903
Bom Dia Vinny e Chico,

Esse é o ponto.

A versão atual em operação é a 3.0.8. No servidor, o PHP esta o 5.4.

Fiz a nova instalação na pasta /phpbb, já na versão 3.2.1.

Sem mexer na versão PHP do servidor, ao acessar a instalação do 3.2.1, apareceu esta mensagem:

"
Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/planilha/public_html/phpbb/common.php on line 26

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/planilha/public_html/phpbb/common.php on line 26

Parse error: syntax error, unexpected T_STRING in /home/planilha/public_html/phpbb/common.php on line 26
"

Esse erro é devido a versão do PHP do servidor?
Avatar do usuário
By _Vinny_
Avatar
#295904
Eron_moraes escreveu: 28 Out 2017, 08:17 Esse erro é devido a versão do PHP do servidor?
Sem duvida. Mude para a versão 5.6 que suporta tanto o phpBB 3.0 e também 3.2 :thumbsup:
Assim acredito que você possa trabalhar sem erros e problemas de compatibilidade.

Experimente limpar o cache do navegador

O erro já foi corrigido sozinho. obrigado

uso xampp, vou aumentar aqui, já tive um pr[…]

Então Lucas... Fiz sim... Inclusive peguei […]